Problem from install lpwanserver

Hello colleagues, I tried to install your lpwanserver product but I get errors when I run npm install in lpwa directory
I would appreciate some help and a hint as to what I’m doing wrong

git clone
$ cd lpwanserver
$ npm install

output npm-debug.log
108306 error Linux 4.4.0-142-generic
108307 error argv “/usr/bin/nodejs” “/usr/bin/npm” “install”
108308 error node v4.2.6
108309 error npm v3.5.2
108310 error file sh
108311 error code ELIFECYCLE
108312 error errno ENOENT
108313 error syscall spawn
108314 error grpc@1.21.1 install: node-pre-gyp install --fallback-to-build --library=static_library
108314 error spawn ENOENT
108315 error Failed at the grpc@1.21.1 install script ‘node-pre-gyp install --fallback-to-build --library=static_library’.
108315 error Make sure you have the latest version of node.js and npm installed.
108315 error If you do, this is most likely a problem with the grpc package,
108315 error not with npm itself.
108315 error Tell the author that this fails on your system:
108315 error node-pre-gyp install --fallback-to-build --library=static_library
108315 error You can get information on how to open an issue for this project with:
108315 error npm bugs grpc
108315 error Or if that isn’t available, you can get their info via:
108315 error npm owner ls grpc
108315 error There is likely additional logging output above.
108316 verbose exit [ 1, true ]

I use Ubuntu 16.04.6 LTS / npm -v 3.5.2 / nodejs -v v4.2.6

curl -sL | sudo bash 
$ sudo apt install nodejs

Hi @goldware. I believe this will be resolved if you update Node and NPM to versions at or higher than those specified in package.json. If you are on Mac or Unix, I like to use nvm to install Node.js and NPM.
It makes it easy to switch between versions, but also helps in avoiding permissions errors on some npm installs.

Thanks you @rhythnic this Worked :+1: